广东南粤风采36选7最近开奖结果 http://www.bavghg.tw 分享精品單機游戲手機應用和軟件下載資源 Mon, 24 Jun 2019 11:09:26 +0000 zh-CN hourly 1 https://wordpress.org/?v=5.2.2 VBoxManage對虛擬機格式vdi、vmdk、vhd進行互轉 http://www.bavghg.tw/archives/12723.html http://www.bavghg.tw/archives/12723.html#respond Mon, 01 Jul 2019 01:54:13 +0000 http://www.bavghg.tw/?p=12723 虛擬機格式簡介

利用VBoxManage如何對三種常見的虛擬機文件格式進行轉換,首先讓我們了解一下這三種格式:

vdi格式 :

VirtualBox默認創建的硬盤文件格式,(關于VirtualBox 原是德國一家軟件公司InnoTek所開發的虛擬系統軟件,后被SUN收購,而后SUN又被Oracle收購,VirtualBox 是一款功能強大的虛擬機軟件,不僅具有豐富的特色,而且性能也很優異)

vmdk格式:

VMware創建的虛擬硬盤文件格式,(關于VMware,在虛擬機領域可以說是全球最牛B的公司,目前為EMC的全資子公司)

vhd格式:

為微軟虛擬機硬盤文件格式,(關于微軟虛擬機技術,從最初的VPC,VServer2005r2 ,Hyper-v2008,Hyper-v2008R2,到這會的hyper-v 8beta,歷經多重改進,在新版本的Hyper-v 8beta中,將會發現有非常令人Exciting 的 Feature,如新的硬盤格式VHDX的出現,空間技術從2T提升至16T,保護數據并確保大型扇區磁盤上的質量性能等)

轉換方法

這三種虛擬硬盤格式的互相轉換可以通過一些第三方工具軟件進行,此文我們介紹如何利用VirtualBox 自帶的VBoxManage來進行格式轉換:

1.VBoxManage.exe在VirtualBox 安裝目錄下,如下圖,我們進VirtualBox 安裝目錄查看到VBoxManage.exe

VBoxManage對虛擬機格式vdi、vmdk、vhd進行互轉

2.命令行進入VirtualBox目錄,運行相關VBoxManage格式轉換指令,語法如下:

VBoxManage clonehd 源硬盤格式文件 目錄硬盤格式文件 –format 目標格式后綴

3.將VDI文件轉成VHD文件,如下圖命令將vdi的虛擬機文件轉換成微軟vhd虛擬機文件:

VBoxManage對虛擬機格式vdi、vmdk、vhd進行互轉

執行進度至100%結束完成轉換,隨后我們用微軟虛擬機軟件掛載順利運行

至此,利用VBoxManage對三種常見虛擬硬盤格式轉換介紹結束,vmdk、vhd轉VDI等按格式套用即可。

VHDX虛擬文件介紹

VHDX 格式的主要新功能如下:

支持的虛擬硬盤的存儲容量高達 16 TB。
通過記錄對 VHDX 元數據結構的更新,可以在電源發生故障時保護數據不會被損壞。
改進了虛擬硬盤格式的對齊方式,可在大型扇區磁盤上更好地工作。
VHDX 格式還提供以下功能:

動態磁盤和差異磁盤較大的數據塊大小,可讓這些磁盤滿足工作負荷的需求。
一個 4 KB 的邏輯扇區虛擬磁盤,可以在為 4 KB 扇區設計的應用程序和工作負荷使用該磁盤時提供較高的性能。
能夠存儲有關用戶可能想記錄的文件的自定義元數據,如操作系統版本或應用的修補程序。
高效地表示數據(也稱為“剪裁”),使文件大小更小并且允許基礎物理存儲設備回收未使用的空間。(剪裁需要直接連接到虛擬機或 SCSI 磁盤的物理磁盤以及與剪裁兼容的硬件。)


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->VBoxManage對虛擬機格式vdi、vmdk、vhd進行互轉!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12723.html/feed 0
Windows 系統下搭建svn(Subversion)服務器端 http://www.bavghg.tw/archives/12721.html http://www.bavghg.tw/archives/12721.html#respond Mon, 01 Jul 2019 01:45:17 +0000 http://www.bavghg.tw/?p=12721 Windows 系統下搭建svn(Subversion)服務器端

軟件

1)服務端:Subversion

subversion.apache.org – Getting Subversion – Binary Packages – Windows – Win32Svn – Files – 1.6.16 – svn-win32-1.6.16.zip

解壓svn-win32-1.6.16.zip到C:\My Program Files

2)客戶端:TortoiseSVN

tortoisesvn.tigris.org – tortoisesvn.net/downloads – TortoiseSVN 32-bit – downloads.sourceforge.net/tortoisesvn/TortoiseSVN-1.6.15.21042-win32-svn-1.6.16.msi

直接安裝

步驟

1)添加C:\My Program Files\Subversion\bin到環境變量(貌似不一定需要)

2)新建目錄E:\svn_repository\svn

3)進入E:\svn_repository\svn – 右鍵 – TortoiseSVN – creat repository here

或者在cmd下輸入以下命令:

C:\My Program Files\svn-win32-1.6.16\bin\svnadmin create E:\svn_repository\svn

4)文本打開E:\svn_repository\svn\conf\svnserve.conf – 修改“# password-db = passwd”為“password-db = passwd”

5)文本打開E:\svn_repository\svn\conf\passwd – 添加用戶“root = pwd”

6)添加系統服務:cmd下(命令行中等號前不能有空格,等號后必須有空格)

C:\>sc create svnserver binpath= “C:\My Program Files\svn-win32-1.6.16\bin\svnserve.exe –service –root E:\svn_repository” displayname= “svnserver” depend= tcpip start= auto obj= “NT AUTHORITY\NetworkService”

[SC] CreateService SUCCESS

7)svn的使用不說了

可能遇到的問題

1)在commit的時候出現錯誤“不能打開文件“E:\svn_repository\svn\db\txn-current-lock”: 拒絕訪問。”

解決辦法:為E:\svn_repository目錄設置寫權限,用戶組”Administrator/Users”需要有修改、寫入權限。

打開E:\svn_repository目錄 – 工具 – 文件夾選項 – 查看 – 不要選中“使用簡單文件共享” – 確定 – 右擊空白處 – 屬性 – 安全 – 選中Users組 – 在“允許”下勾選“修改”和“寫入”

2)Windows 7下添加系統服務時出現 “[SC] OpenSCManager 失敗 5:” 錯誤

解決方法:開始——所有程序——附件——(右鍵)命令提示符——以管理員身份運行

3)啟動服務時出現“錯誤5 拒絕訪問”

解決方法:為C:\My Program Files\svn-win32-1.6.16文件夾添加user用戶使用權限

右擊文件夾——屬性——安全——添加“users”用戶——權限默認即可

4)啟動服務時出現“錯誤 1053”

檢查是否創建了E:\svn_repository文件夾

其他

1)刪除服務

C:\>sc delete svnserver


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->Windows 系統下搭建svn(Subversion)服務器端!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12721.html/feed 0
易語言倒計時器源碼(每隔5分鐘執行一次并在五分鐘內倒計時) http://www.bavghg.tw/archives/12729.html http://www.bavghg.tw/archives/12729.html#respond Mon, 24 Jun 2019 11:09:18 +0000 http://www.bavghg.tw/?p=12729 易語言倒計時器源碼(每隔5分鐘執行一次并在五分鐘內倒計時)

源碼簡介

易語言寫一個倒計時器,就是說。比如一個程序要每隔5分鐘執行一次。讓他這五分鐘內倒計時

源碼1

版本 2
.子程序 取倒計時間, 文本型, , 返回“天數-時-分-秒”的文本格式,時間部分可參考參數變量
.參數 起始時間, 日期時間型
.參數 終了時間, 日期時間型
.參數 小時, , 參考 可空, 倒數出‘小時’整數部分
.參數 分鐘, , 參考 可空, 倒數出‘分鐘’整數部分
.參數 秒數, , 參考 可空, 倒數出‘秒數’整數部分
.局部變量 天數, 雙精度小數型
.局部變量 小時_, 雙精度小數型
.局部變量 分鐘_, 雙精度小數型
.局部變量 秒數_, 雙精度小數型
.局部變量 文本_天數, 文本型
.局部變量 文本_小時, 文本型
.局部變量 文本_分鐘, 文本型
.局部變量 文本_秒數, 文本型
天數 = 取時間間隔 (終了時間, 起始時間, #日)
小時_ = (天數 - 到整數 (天數)) × 24
分鐘_ = (小時_ - 到整數 (小時_)) × 60
秒數_ = (分鐘_ - 到整數 (分鐘_)) × 60
秒數_ = 四舍五入 (秒數_, )
文本_天數 = 到文本 (到整數 (天數) + 1) + “天”
小時 = 到整數 (小時_)
分鐘 = 到整數 (分鐘_)
秒數 = 秒數_
.如果 (小時_ < 10)
文本_小時 = “0” + 到文本 (到整數 (小時_)) + “時”
.否則
文本_小時 = 到文本 (到整數 (小時_)) + “時”
.如果結束
.如果 (分鐘_ < 10)
文本_分鐘 = “0” + 到文本 (到整數 (分鐘_)) + “分”
.否則
文本_分鐘 = 到文本 (到整數 (分鐘_)) + “分”
.如果結束
.如果 (秒數_ < 10)
文本_秒數 = “0” + 到文本 (秒數_) + “秒”
.否則
文本_秒數 = 到文本 (秒數_) + “秒”
.如果結束
返回 (文本_天數 + 文本_小時 + 文本_分鐘 + 文本_秒數)
事例:
取倒計時間 (取現行時間 (), 到時間 (“2012-7-20-0:0:0”))
 搶首贊    1  評論 分享 舉報 收起
菲菲88952 
2012-07-02
.版本 2(別的是 復制的)
.程序集 窗口程序集1
.子程序 _按鈕1_被單擊
編輯框1.內容 = “05:00”
.如果 (按鈕1.標題 = “開始倒計時”)
按鈕1.標題 = “停止倒計時”
時鐘1.時鐘周期 = 1000
.否則
按鈕1.標題 = “開始倒計時”
時鐘1.時鐘周期 = 0
.如果結束
.子程序 _時鐘1_周期事件
編輯框1.內容 = 倒記時 (到整數 (取文本左邊 (編輯框1.內容, 2)), 到整數 (取文本右邊 (編輯框1.內容, 2)))
.子程序 倒記時, 文本型, , 00:00
.參數 分鐘, 整數型
.參數 秒鐘, 整數型
.局部變量 局_剩余分文本, 文本型
.局部變量 局_剩余秒文本, 文本型
.如果真 (分鐘 = 0)
.如果真 (秒鐘 = 0)
運行 (“你要運行的程序.exe”, 假, )
返回 (“05:00”)
.如果真結束
.如果真結束
.如果真 (秒鐘 = 0)
秒鐘 = 60
分鐘 = 分鐘 - 1
.如果真結束
秒鐘 = 秒鐘 - 1
局_剩余分文本 = 到文本 (分鐘)
局_剩余秒文本 = 到文本 (秒鐘)
.如果真 (取文本長度 (到文本 (分鐘)) < 2)
局_剩余分文本 = “0” + 到文本 (分鐘)
.如果真結束
.如果真 (取文本長度 (到文本 (秒鐘)) < 2)
局_剩余秒文本 = “0” + 到文本 (秒鐘)
.如果真結束
返回 (局_剩余分文本 + “:” + 局_剩余秒文本)

源碼2

.版本 2(別的是 復制的)
.程序集 窗口程序集1
.子程序 _按鈕1_被單擊
編輯框1.內容 = “05:00”
.如果 (按鈕1.標題 = “開始倒計時”)
按鈕1.標題 = “停止倒計時”
時鐘1.時鐘周期 = 1000
.否則
按鈕1.標題 = “開始倒計時”
時鐘1.時鐘周期 = 0
.如果結束
.子程序 _時鐘1_周期事件
編輯框1.內容 = 倒記時 (到整數 (取文本左邊 (編輯框1.內容, 2)), 到整數 (取文本右邊 (編輯框1.內容, 2)))
.子程序 倒記時, 文本型, , 00:00
.參數 分鐘, 整數型
.參數 秒鐘, 整數型
.局部變量 局_剩余分文本, 文本型
.局部變量 局_剩余秒文本, 文本型
.如果真 (分鐘 = 0)
.如果真 (秒鐘 = 0)
運行 (“你要運行的程序.exe”, 假, )
返回 (“05:00”)
.如果真結束
.如果真結束
.如果真 (秒鐘 = 0)
秒鐘 = 60
分鐘 = 分鐘 - 1
.如果真結束
秒鐘 = 秒鐘 - 1
局_剩余分文本 = 到文本 (分鐘)
局_剩余秒文本 = 到文本 (秒鐘)
.如果真 (取文本長度 (到文本 (分鐘)) < 2)
局_剩余分文本 = “0” + 到文本 (分鐘)
.如果真結束
.如果真 (取文本長度 (到文本 (秒鐘)) < 2)
局_剩余秒文本 = “0” + 到文本 (秒鐘)
.如果真結束
返回 (局_剩余分文本 + “:” + 局_剩余秒文本)

版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->易語言倒計時器源碼(每隔5分鐘執行一次并在五分鐘內倒計時)!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12729.html/feed 0
VirtualBox 常見操作方法及說明 http://www.bavghg.tw/archives/12720.html http://www.bavghg.tw/archives/12720.html#respond Sun, 23 Jun 2019 01:44:50 +0000 http://www.bavghg.tw/?p=12720 VirtualBox 常見操作方法及說明
對vm的修改,只能在其停機后進行,否則不會成功的。

整機克隆

從4.2版開始,加入了虛擬機整機克隆,并解決因網卡、磁盤的uuid相同的問題(當然操作系統的’udev’設置管理也要支持)
VBoxManage clonevm |
[–snapshot |]
[–mode machine|machineandchildren|all]
[–options link|keepallmacs|keepnatmacs|keepdisknames]
[–name ]
[–basefolder ]
[–uuid ]
[–register]

$ VBoxManage clonevm ocentos –mode all –name pcentos –basefolder /data/vmos/ –register
0%…10%…20%…30%…40%…50%…60%…70%…80%…90%…100%

VBoxManage clonevm pde –mode all –name origde –basefolder /home/hto/data/vmos/ –register

解決了之前要克隆一臺虛擬機要經過若干個步驟,有些麻煩,現在一條指令即可實現。

移除虛擬機

反注冊:VBoxManage unregistervm router
現在列出時(VBoxManage list vms)可以看到’router’這臺vm沒有出現。

如果想把這臺虛擬機再重新注冊回來,可以使用(VBoxManage registervm /data/vmos/router/router.vbox)來將這臺vm加入到可用虛擬機列表中,前提是沒有刪除與之相關的文件(包括從VBoxManage操作或直接文件刪除)。

注意:虛擬機在刪除時不能直接去相應目錄從文件層面上進行刪除,那樣導致vbox報錯。應在反注冊時加上’–delete’參數從系統中徹底清除該虛擬機,如果再想要找回該虛擬機時就不可能了,所以在操作前一定要想好(在windows下并沒有真正刪除文件)。

創建host-only網絡接口

VBoxManage hostonlyif create
會創建一個命為’vboxnet0’這樣一個網口,前提為目前沒有創建過,如果已經有一塊這樣的網口的話,將會以’vboxnet1’這樣的方式來命名。它自動使用’192.168.56.1’這樣的dhcp方式分配的ip地址,你可以為它更改。
VBoxManage hostonlyif ipconfig vboxnet0 –ip 192.168.18.3 –netmask 255.255.255.224

注意:創建了這樣一個網口,但在宿主機上通過’ifconfig’不能看到,因為虛擬機沒有使用到它,只有當它被使用時,才會在宿主機上看到。

在4.1下發現這樣一個問題:宿主機僅有一個網口(eth0),采用vyatta做虛擬機的路由,它的主機名為router,在router上虛擬兩張網卡,eth0與eth1:前者接入局域網(bridged),后者(bridged)通過前者連網,且兩者在不同網段。在vm1上的網卡(bridged)設置好與router的eth1相關的地址后,剛開始能通過router連接到互聯網的主機,但過一會兒,網絡開始不通,有時根本就不能通。而4.0沒有此現象,后不得不將它們的連接方式改為’hostonlyif’這種。

VBoxManage modifyvm scentos –cpus 2 –memory 1024 –nic1 hostonly –hostonlyadapter1 vboxnet0

為虛擬機另加磁盤

首先需要將運行的機器關閉,運行’VBoxManage list -l vms’看下該虛擬機磁盤控制器使用的情況:
Storage Controller Name (0): SATA Controller
Storage Controller Type (0): IntelAhci
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 30
Storage Controller Port Count (0): 30
Storage Controller Bootable (0): on
SATA Controller (0, 0): /data/vmos/srouter/srouter.vdi (UUID: 66a94588-4909-479f-abd2-1d266ed017c9)
SATA Controller (1, 0): /home/hto/sf/os/vyatta-livecd_6.2.i386.iso (UUID: 0938dde8-5aa3-4c2a-a473-115f91d0c061)

已經有兩個端口被用了,這里再為它加一個。
VBoxManage storageattach pcentos –storagectl “SATA Controller” –port 2 –device 0 –type hdd –medium /data/vmos/disk/pdisk0.vdi

—————
將’.img’鏡像文件轉為VDI格式的固態虛擬文件

D:\data\vmos\bsdrouter>vboxmanage convertfromraw –format VDI –variant Fixed BSDRP-1.4-full-i386-vga.img bsdrp-full.vdi

Converting from raw image file=”BSDRP-1.4-full-i386-vga.img” to file=”bsdrp-full.vdi”…
Creating fixed image with size 256000000 bytes (245MB)…

—————

克隆磁盤鏡像(固定格式)

VBoxManage clonehd src_vdi_img des_vdi_img –format VDI –variant Fixed

ssh遠程管理虛擬機

在宿主操作系統沒有gui時,需要通過vrde協議來連接宿主上的某一端口來安裝,或者通過ssh 的’X’轉發來實現。

將虛擬機跨機器遷移

直接將’vdi’格式的鏡像通過網絡傳到另外一臺機器,vbox版本不要跨太多。下面是一個將windows平臺的虛擬機磁盤文件移到高版本的linux虛擬機下。

VBoxManage storagectl “winxp” –name “IDE Controller” –add ide –controller PIIX4 –hostiocache on –bootable on
VBoxManage: error: Storage controller named ‘IDE Controller’ already exists
VBoxManage: error: Details: code VBOX_E_OBJECT_IN_USE (0x80bb000c), component SessionMachine, interface IMachine, callee nsISupports
Context: “AddStorageController(Bstr(pszCtl).raw(), StorageBus_IDE, ctl.asOutParam())” at line 879 of file VBoxManageStorageController.cpp

hto@debian:~$ VBoxManage storagectl “winxp” –name “IDE Controller” –remove
hto@debian:~$ VBoxManage storagectl “winxp” –name “IDE Controller” –add ide –controller PIIX4 –hostiocache on –bootable on
hto@debian:~$ VBoxManage storageattach “winxp” –storagectl “IDE Controller” –port 0 –device 0 –type hdd –medium /home/hto/data/vmos/winxp/winxp.vdi

VirtualBox 4.3 啟動虛擬機時顯示不能加載 R3模塊并退出故障

不能為虛擬電腦打開一個新任務

Unable to load R3 module D:\programfiles\oracle\vbox/VBoxDD.DLL (VBoxDD): GetLastError=1790 (VERR_UNRESOLVED_ERROR).

返回 代碼:E_FAIL (0x80004005)
組件:Console
界面:IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

VirtualBox 升級到 4.3后一直問題不斷。發現從最近的某個版本開始,為了安全,要校驗進程完整性,那些在運行時要注入Virtualbox進程的模塊都要進行校驗。于是便出現了軟件不兼容等等故障。查一下日志,發現一行:
supR3HardenedErrorV: supR3HardenedMonitor_LdrLoadDll: rejecting ‘C:\Windows\system32\uxtheme.dll’: rcNt=0xc0000190

這是因為破解了系統主題文件uxtheme.dll的原因,只能還原系統主題文件uxtheme.dll,再次啟動虛擬機就可以了。

解決方法

恢復系統主題文件即可。

完全的參考地址:http://www.aixq.com/post-328.html

日常使用vboxmanage的總結

顯示所有虛擬機:vboxmanage list vms

顯示所有正在運行的虛擬機:vboxmanage list runningvms

顯示虛擬機詳細信息:vboxmanage showvminfo winxp

修改虛擬機名稱:vboxmanage modifyvm winxp –name winxp_clone

修改虛擬機所占用的cpu內核數:vboxmanage modifyvm winxp –cpus 2

修改虛擬機所占用的內存數量(默認為MB):vboxmanage modifyvm winxp –memory 2048

啟動虛擬機:vboxmanage startvm winxp –type gui|sdl|headless
在gui環境下默認為gui,也可以使用sdl視頻驅動;在沒有gui的情況下使用headless在后臺啟動,當然前提是該vm已經配置好遠程連接方式(遠程桌面或ssh)。

正常關閉機器:vboxmanage controlvm winxp acpipowerbutton

強行關閉虛擬機:vboxmanage controlvm winxp poweroff

克隆并注冊虛擬機:vboxmanage clonevm winxp –name winxp2 –register

修改端口映射規則(將宿主機的本機端口對應到vm上某端口):vboxmanage modifyvm winxp –natpf1 rule_ssh, tcp, , 8888, 10.0.2.16, 8888

將網絡連接修改成橋接:vboxmanage modifyvm winxp –nic1 bridged –bridgeadapter1 eth0
需要注意的是,接口的編號與新式的linux系統網口編號相似,從1而不是0開始。

磁盤控制器

IDE控制器

創建:
VBoxManage storagectl testvm –name “IDE Controller” –add ide

卸載
VBoxManage storagectl testvm –name “IDE Controller” –remove

SATA Controller

VBoxManage storagectl testvm –name “SATA Controller” –add sata

控制芯片:–controller,主流的選擇:IntelAHCI,較低端的用:ICH6,非常早的主板用:PIIX3、4。–sataportcount,用于指定sata的端口號(1-30)。

–hostiocache,是否使用宿主機的I/O緩存。

–bootable,該盤是否可引導。

磁盤存儲設備管理

刪除存儲設備

VBoxManage closemedium disk /home/freeoa/winxp.vdi –delete

重新設置存儲設備在vbox中的uuid,其中my-uuid為指定的新uuid
VBoxManage storageattach “testvm” –storagectl “IDE Controller” –port 1 –device 0 –type hdd –medium /home/freeoa/winxp.vdi –setuuid my-uuid

顯示磁盤信息

$ vbm showhdinfo ~/data/vm/xp/winxp.vdi
UUID:1595311c-3020-4c7a-a311-5c316ffbc7b7
Accessible:yes
Logical size:6144 MBytes
Current size on disk: 6144 MBytes
Type:normal (base)
Storage format:VDI
Format variant:fixed default
In use by VMs:xp (UUID: ba2f1edb-3d4a-4e74-8680-0623f94fefce)
Location:/home/hto/data/vm/xp/winxp.vdi

為虛擬硬盤重新分配UUID,即克隆指定的VDI虛擬硬盤
vbm clonehd | |
VBoxManage clonehd my-uuid /home/hto/data/vm//testvm/testvm2.vdi

修改
VBoxManage convertfromraw
[–format VDI|VMDK|VHD]
[–variant Standard,Fixed,Split2G,Stream,ESX]
[–uuid ] 將raw硬盤轉換成vdi虛擬硬盤

VBoxManage modifyhd |
[–type normal|writethrough|immutable|shareable|readonly|multiattach]
[–autoreset on|off]
[–compact] 壓縮指定的虛擬硬盤
[–resize |–resizebyte ] 調整其空間大小,對分配了固定大小的磁盤好像無效

掛載到磁盤控制器

VBoxManage storageattach testvm –storagectl “IDE Controller” –port 0 –device 0 –type hdd –medium /home/hto/data/vm/testvm/testvm.vdi

卸載
VBoxManage storageattach testvm –storagectl “IDE Controller” –port 0 –device 0 –type hdd –medium none

空置占位
VBoxManage storageattach testvm –storagectl “IDE Controller” –port 0 –device 0 –type hdd –medium emptydrive

虛擬光盤

掛載虛擬光盤
VBoxManage storageattach testvm –storagectl “IDE Controller” –port 1 –device 0 –type dvddrive –medium /usr/share/virtualbox/VBoxGuestAdditions.iso

卸載虛擬光盤
VBoxManage storageattach testvm –storagectl “IDE Controller” –port 1 –device 0 –type dvddrive –medium none

移|刪除vbox中的存儲設備(磁盤)

$ vbm showvminfo winxp

Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): /home/freeoa/data/vmos/winxp/winxproxy.vdi (UUID: 54d85901-2cfd-426e-ae2d-20f5cd08fc7b)
IDE Controller (0, 1): /home/freeoa/swork/vmos/disk/winxp.dlext.vdi (UUID: a310850f-3ce1-4418-8d61-f960742dec96)

$ vbm storageattach winxp –storagectl “IDE Controller” –port 1 –device 0 –type hdd –medium none
VBoxManage: error: No storage device attached to device slot 0 on port 1 of controller ‘IDE Controller’
VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component SessionMachine, interface IMachine, callee nsISupports
VBoxManage: error: Context: “DetachDevice(Bstr(pszCtl).raw(), port, device)” at line 381 of file VBoxManageStorageController.cpp

$ vbm storageattach winxp –storagectl “IDE Controller” –port 1 –device 0 –type hdd –medium emptydrive

IDE Controller (0, 0): /home/freeoa/data/vmos/winxp/winxproxy.vdi (UUID: 54d85901-2cfd-426e-ae2d-20f5cd08fc7b)
IDE Controller (0, 1): /home/freeoa/swork/vmos/disk/winxp.dlext.vdi (UUID: a310850f-3ce1-4418-8d61-f960742dec96)
IDE Controller (1, 0): Empty

成這樣了,還來還是在port 0上,

$ vbm storageattach winxp –storagectl “IDE Controller” –port 0 –device 1 –type hdd –medium none
成功了。

Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): /home/freeoa/data/vmos/winxp/winxproxy.vdi (UUID: 54d85901-2cfd-426e-ae2d-20f5cd08fc7b)

這里只是將這個虛擬磁盤從虛擬機中移除了,但磁盤文件依然存在的vbox中(其uuid在本機中是注冊過了的),只是沒有被用罷了;如果有連磁盤文件刪除,可以這樣操作:
$ vbm closemedium disk /home/freeoa/swork/vmos/disk/winxp.dlext.vdi –delete
0%…10%…20%…30%…40%…50%…60%…70%…80%…90%…100%

對virtualbox中storagectl的 port 與 device 理解

其中的device是存儲樹的按添加存儲器的順序來標號的(與c語言中的標號一樣,從0開始),像如下這個:
IDE (1, 0): Empty
SATA (0, 0): D:\data\vmos\clinx\clinx.vdi (UUID: b8d5efea-4edc-4daa-8a01-3606f9d7a804)
SATA (1, 0): E:\software\os\debian\debian-7.11-amd64-netinst.iso (UUID: 89fd152f-1127-4ae6-b493-61c308ed4537)

IDE在SATA設備之上,所以它先于被發現,為什么它倆設備編號是從0開始的呢?

因為它們不是同一設備(一個IDE一個SATA)。

port則是在該設備中的接入的磁盤順序,同樣也是從0開始計數。如上的結果,clinx.vdi就先于debian-7.11-amd64-netinst.iso被發現,因此編號在這個設備中是最小的。

存儲設備的編寫規則為:
Storage Controller(port,device)

port是跟著device走的。

常用指令參考

#列出全部虛擬機
VBoxManage list vms
#列出全部運行中的虛擬機
VBoxManage list runningvms
#列出虛擬機信息
VBoxManage showvminfo uuid|vmname
#開啟虛擬機
VBoxManage startvm uuid|vmname
#開啟虛擬機,無GUI模式
VBoxManage startvm uuid|vmname –type headless
#暫停虛擬機
VBoxManage controlvm uuid|vmname pause
#繼續運行虛擬機
VBoxManage controlvm uuid|vmname resume
#按下機箱重啟按鈕
VBoxManage controlvm uuid|vmname reset
#直接斷電
VBoxManage controlvm uuid|vmname poweroff
#按下機箱電影按鈕
VBoxManage controlvm uuid|vmname acpipowerbutton
#按下機箱睡眠按鈕
VBoxManage controlvm uuid|vmname acpisleepbutton

VBoxManage [-v|-version] 顯示virtualbox的版本號
VBoxManage -nologo 隱藏logo
VBoxManage -convertSettings 允許自動轉換設置文件
VBoxManage -convertSettingsBackup 允許自動轉換設置文件,并在轉換前作備份
VBoxManage -convertSettingsIgnore 允許自動轉換設置文件,但是不保存結果

VBoxManage list vms|runningvms 顯示列表虛擬機|正在運行的虛擬機
|ostypes|hostdvds virtualbox支持的系統類型|宿主機的光盤驅動器
|hostfloppies 宿主機的軟盤驅動器
|hostifs|hostinfo 宿主機的網絡接口|宿主機的信息
|hdds|dvds 已注冊的虛擬硬盤|已注冊的虛擬光盤
|floppies|usbhost 已注冊的虛擬軟盤|宿主機的USB設備
|usbfilters USB篩選器
|systemproperties 虛擬機的基本信息

VBoxManage showvminfo | 顯示指定虛擬機的信息
[–details] 顯示詳細信息
[–statistics] 顯示統計信息
[–machinereadable] 以清晰的格式顯示虛擬機信息

VBoxManage registervm 將指定文件所在的虛擬機添加到列表

VBoxManage unregistervm | 從虛擬機列表清除指定的虛擬機
[-delete] 從虛擬機列表刪除指定的虛擬機

VBoxManage createvm -name 創建指定名稱的虛擬機
[-register] 將創建的虛擬機添加到列表
[-basefolder 指定虛擬機的基礎目錄
[-settingsfile ] 指定虛擬機配置文件的基礎目錄
[-uuid ] 創建指定uuid的虛擬機

VBoxManage modifyvm 編輯指定的虛擬機的配置
[-name ] 修改虛擬機的名稱
[-ostype ]修改虛擬機的操作系統類型
[-memory ] 修改虛擬機的內存大小
[-vram ] 修改虛擬機的顯存大小
[-acpi on|off] 啟動或禁止acpi電源管理接口
[-ioapic on|off] 啟動或禁止I/O APIC電源管理接口
[-pae on|off] 啟動或禁止CPU的PAE支持,PAE是
Physical Address Extension : 物理地址擴展
[-hwvirtex on|off|default]啟動或禁止CPU的硬件虛擬化支持
[-nestedpaging on|off] 開啟或關閉CPU的嵌套頁面列表支持
[-monitorcount ] 設置顯示器數目,VRDP多用戶模式時 [-bioslogofadein on|off] 開啟或關閉bioslogo漸顯效果
[-bioslogofadeout on|off] 開啟或關閉bioslogo漸隱效果
[-bioslogodisplaytime ]設置bioslogo顯示時間(以毫秒為單位)
[-bioslogoimagepath ]設置bioslogo圖像路徑,用于自定義bioslogo
[-biosbootmenu disabled| 設置是否顯示bios啟動菜單 關閉
menuonly| 只顯示菜單
messageandmenu] 信息和菜單
[-biossystemtimeoffset ] 設置bios系統時間補償(以毫秒為單位)
[-biospxedebug on|off] 打開或關閉biospxe調試
[-boot<1-4> none|floppy|dvd|disk|net] 設置啟動順序

詳細的常用指令參考

啟動虛擬機
VBoxManage startvm 虛擬機名

無前端圖形界面方式啟動虛擬機
VBoxManage startvm 虛擬機名 –type headless

使用 VRDP 方式通過命令行啟動虛擬機:(3389)
VBoxManage startvm 虛擬機名 –type vrdp

關閉虛擬機(強制)
VBoxManage controlvm 虛擬機名 poweroff

VBoxManage [-v|-version] 顯示virtualbox的版本號
VBoxManage -nologo 隱藏logo
VBoxManage -convertSettings 允許自動轉換設置文件
VBoxManage -convertSettingsBackup 允許自動轉換設置文件,并在轉換前作備份
VBoxManage -convertSettingsIgnore 允許自動轉換設置文件,但是不保存結果

VBoxManage list vms|runningvms 顯示列表虛擬機|正在運行的虛擬機
|ostypes|hostdvds virtualbox支持的系統類型|宿主機的光盤驅動器
|hostfloppies 宿主機的軟盤驅動器
|hostifs|hostinfo 宿主機的網絡接口|宿主機的信息
|hdds|dvds已注冊的虛擬硬盤|已注冊的虛擬光盤
|floppies|usbhost 已注冊的虛擬軟盤|宿主機的USB設備
|usbfilters USB篩選器
|systemproperties 虛擬機的基本信息

VBoxManage showvminfo | 顯示指定虛擬機的信息
[-details] 顯示詳細信息
[-statistics] 顯示統計信息
[-machinereadable] 以清晰的格式顯示虛擬機信息

VBoxManage registervm 將指定文件所在的虛擬機添加到列表

VBoxManage unregistervm | 從虛擬機列表清除指定的虛擬機
[-delete] 從虛擬機列表刪除指定的虛擬機

VBoxManage createvm –name 創建指定名稱的虛擬機
[–register] 將創建的虛擬機添加到列表
[–basefolder 指定虛擬機的基礎目錄
[–settingsfile ] 指定虛擬機配置文件的基礎目錄
[–uuid ] 創建指定uuid的虛擬機

VBoxManage modifyvm 編輯指定的虛擬機的配置
[-name ] 修改虛擬機的名稱
[-ostype ]修改虛擬機的操作系統類型
[-memory ] 修改虛擬機的內存大小
[-vram ] 修改虛擬機的顯存大小
[-acpi on|off] 啟動或禁止acpi電源管理接口
[-ioapic on|off] 啟動或禁止I/O APIC電源管理接口
[-pae on|off] 啟動或禁止CPU的PAE支持,PAE是Physical Address Extension : 物理地址擴展
[-hwvirtex on|off|default]啟動或禁止CPU的硬件虛擬化支持
[-nestedpaging on|off] 開啟或關閉CPU的嵌套頁面列表支持
[-monitorcount ] 設置顯示器數目,VRDP多用戶模式時 [-bioslogofadein on|off] 開啟或關閉bioslogo漸顯效果
[-bioslogofadeout on|off] 開啟或關閉bioslogo漸隱效果
[-bioslogodisplaytime ]設置bioslogo顯示時間(以毫秒為單位)
[-bioslogoimagepath ]設置bioslogo圖像路徑,用于自定義bioslogo
[-biosbootmenu disabled| 設置是否顯示bios啟動菜單 關閉
menuonly| 只菜單
messageandmenu] 信息和菜單
[-biossystemtimeoffset ] 設置bios系統時間補償(以毫秒為單位)
[-biospxedebug on|off] 打開或關閉biospxe調試
[-boot<1-4> none|floppy|dvd|disk|net>] 設置啟動順序
[-hd none||] 為虛擬機添加三個IDE設備之一(第2個主盤被vm保留作為光驅,不能占用)在三個IDE中,你可以指定(硬盤)的vdi文件名或者它的UUID
[-idecontroller PIIX3|PIIX4] 設置IDE控制器的類型
[-sata on|off] 開啟或關閉SATA硬盤控制器
[-sataportcount <1-30>] 設置虛擬機最多支持的SATA控制器數目
[-sataport<1-30> none| 沒有硬盤連接到SATA控制器
| 指定uuid的硬盤連接到SATA控制器
] 指定文件名的硬盤連接到SATA控制器
[-sataideemulation<1-4> <1-30>] 指定一個SATA設備工作在IDE兼容模式,IDE設備編號是1-4,SATA設備編號是1-30
[-dvd none| 不連接DVD光驅
| 指定UUID的DVD光驅連接
| 將指定的光盤映像文件掛接到DVD光驅
host:] 將宿主機的DVD光驅掛接到虛擬機的DVD光驅
[-dvdpassthrough on|off]打開|關閉虛擬機里光盤的刻錄功能
[-floppy disabled| 不連接軟驅
empty| 連接軟驅但不插入軟盤
| 指定UUID的軟驅連接
| 將指定的軟盤映像文件掛接到軟驅驅
host:] 將宿主機的軟驅驅掛接到虛擬機的軟驅
[-nic<1-N> none| 虛擬機不添加網卡
null| 虛擬機有網卡但不連接
nat| 網絡連接使用NAT模式
hostif| 網絡連接使用橋接模式
intnet] 網絡連接使用內部網絡模式
[-nictype<1-N> Am79C970A| 虛擬機連接AMD PCNet PCI II網卡
Am79C973| 虛擬機連接AMD PCNet FAST III網卡(默認)
82540EM| 虛擬機連接Intel PRO/1000 MT Desktop網卡
82543GC] 虛擬機連接Intel PRO/1000 T Server網卡
[-cableconnected<1-N> on|off]插入或拔出網線
[-nictrace<1-N> on|off] 開啟或關閉網絡追蹤
[-nictracefile<1-N> ] 將網絡流量追蹤數據保存到文件
[-nicspeed<1-N> ] 設置網絡連接的速度
[-hostifdev<1-N> none| 不連接到主機網絡接口
] 橋接模式下連接到指定的主機接口
[-intnet<1-N> ] 內網模式下為虛擬機指定內部網絡名稱
[-natnet<1-N> | 配置NAT網絡接口的地址
default] 默認NAT網絡接口的地址是10.0.x.0/24
[-macaddress<1-N> auto| 自動生成虛擬網卡的MAC地址
] 指定虛擬網卡的MAC地址
[-uart<1-N> off| 不啟用虛擬串口
]啟用虛擬串口,并設置虛擬串口的I/O參數和IRQ參數
[-uartmode<1-N> disconnected| 啟用虛擬串口,但不連接到宿主機的串口
server | 在宿主機創建PIPE通道,并將虛擬機串口連接到這個通道
client | 不創建PIPE通道,而是將虛擬機串口連接到已存在的通道
] 將虛擬機串口連接到宿主機的串口
[-gueststatisticsinterval ] 配置虛擬機靜態時間間隔
[-audio none| 虛擬機不連接聲卡
null| 將虛擬機的聲卡連接到空的聲音設備
dsound] 將虛擬機的聲卡連接到宿主機的聲卡
[-audiocontroller ac97| 將虛擬機聲卡虛擬為ICH AC97聲卡
sb16] 將虛擬機聲卡虛擬為soundblaster 16聲卡
[-clipboard disabled| 不共享剪貼板
hosttoguest| 將宿主機的剪貼板共享給虛擬機
guesttohost| 將虛擬機的剪貼板共享給宿主機
bidirectional] 宿主機和虛擬機共使用一個剪貼板
[-vrdp on|off] 開啟|關閉virtualbox內置的VRDP服務器
[-vrdpport default| 使用默認的vrdp端口3389 ] 指定vrdp端口
[-vrdpaddress ] 指定VRDP主機地址
[-vrdpauthtype null| 不用授權,任何客戶機都可以連接到VRDP服務器
external| 只有宿主機的用戶才可以連接到VRDP服務器
guest] 只有虛擬機的用戶才可以連接到VRDP服務器
[-vrdpmulticon on|off] 打開|關閉VRDP多用戶連接模式
[-vrdpreusecon on|off] 打開|關閉VRDP斷線重連
[-usb on|off] 打開|關閉虛擬USB控制器
[-usbehci on|off] 打開|關閉虛擬USB2.0控制器
[-snapshotfolder default| 將系統快照保存到默認文件夾 ] 將系統快照保存到指定文件夾

VBoxManage startvm | 開啟指定UUID|名稱的虛擬機
[-type gui|vrdp] 設置虛擬機標準顯示設備GUI界面|VRDP

VBoxManage controlvm | 改變正在運行的虛擬機的狀態
pause| 暫停,這時虛擬機窗口顯示灰色
resume| 恢復暫停的虛擬機
reset| 復位
poweroff| 強行關閉
acpipowerbutton| 關機
acpisleepbutton| 使虛擬機處于睡眠狀態
savestate| 保存狀態然后關閉,相當于休眠
keyboardputscancode [ …] 鍵盤掃描碼設置
setlinkstate<1-4> on|off 連接|斷開網絡連接
usbattach |

連接到指定UUDI|地址的USB設備
usbdetach |

斷開指定UUDI|地址的USB設備
dvdattach none| 不連接虛擬DVD光驅
| 連接到指定UUID的DVD光驅
| 連接到指定名稱的DVD映像文件
host: 連接到宿主機的DVD光驅
floppyattach none| 不連接虛擬軟驅
| 連接到指定UUID的虛擬軟驅
| 連接到指定名稱的軟盤映像文件
host: 連接到宿主機的軟驅

setvideomodehint 設置虛擬機的屏幕分辨率 水平像素
垂直像素
顏色深度
[display] 刷新頻率
setcredentials 指定VRDP自動連接參數 用戶名 密碼

[-allowlocallogon ] 允許|禁止本地登陸

VBoxManage discardstate | 丟棄指定UUID|名稱的虛擬機的保存狀態

VBoxManage adoptstate | 將虛擬機從指定的保存狀態中恢復

VBoxManage snapshot | 為指定的虛擬機拍快照
take 為快照取名
[-desc ]| 給快照添加描述
discard | | 丟棄指定的快照
discardcurrent -state| 恢復到最近的快照
-all | 恢復到倒數第二個快照
edit || 編輯指定的快照
-current 編輯當前快照
[-newname ] 修改快照名稱
[-newdesc ] 修改快照描述

VBoxManage showvminfo | 顯示快照的虛擬機信息

VBoxManage registerimage disk|dvd|floppy 注冊硬盤、光盤、軟盤映像文件
[-type normal| 注冊為普通類型(可創建快照,可讀寫)
immutable| 注冊為只讀類型(相當于加了硬盤卡)
writethrough] 注冊為可寫類型(這種類型不能創建快照)
(disk only) (注冊類型選項只適用于硬盤)

VBoxManage unregisterimage disk| 從虛擬介質管理器刪除指定的硬盤
dvd| 從虛擬介質管理器刪除指定的DVD光盤
floppy 從虛擬介質管理器刪除指定的軟盤
| 刪除時指定UUID
刪除時指定映像文件

VBoxManage showvdiinfo | 顯示指定UUID|名稱虛擬硬盤的信息

VBoxManage createvdi-filename 創建指定名稱的虛擬硬盤
-size 指定虛擬硬盤的大小(以兆為單位)
[-static] 創建固定大小的虛擬硬盤
[-comment ] 添加一段解釋性文字
[-register] 注冊新創建的虛擬硬盤
[-type normal| 注冊類型 普通(可以創建快照)
writethrough] 注冊類型 可寫(不能創建快照)
(default: normal) 默認是普通類型

VBoxManage modifyvdi| compact 壓縮指定的虛擬硬盤

VBoxManage clonevdi | 克隆指定的VDI虛擬硬盤

VBoxManage convertdd[-static] 將raw硬盤轉換成vdi虛擬硬盤

VBoxManage convertdd[-static] stdin 將標準輸入參數指定的設備轉換成vdi虛擬硬盤,比如:dd if=/dev/sda1 | VBoxManage convertdd stdin /media/disk/c.vdi


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->VirtualBox 常見操作方法及說明!在下邊可以分享本文哦!
]]> http://www.bavghg.tw/archives/12720.html/feed 0 AMD 64×2 X000+ CPU溫度高自動關機終級解決方法 http://www.bavghg.tw/archives/12705.html http://www.bavghg.tw/archives/12705.html#respond Sat, 22 Jun 2019 17:19:08 +0000 http://www.bavghg.tw/?p=12705 AMD Athlon速龍64 X2 雙核5000+ 5200+ 4000+ 4200+ 等CPU溫度高自動關機終級解決方法

方法一

CPU墊高(推薦)

最佳,最有效,最簡單,最直接的把CPU降溫的方法。具體操作:把AMD cpu取下,在其四個角用名片紙或其它硬紙用剪刀剪成四個小角,墊在CPU的座子上,然后再把CPU裝上即可。這樣操作,相當于把CPU通過墊高,將其抬起來。

這樣操作

好處一:CPU抬高后,CPU下面可以通風散熱。

好處二:CPU的針腳無需插入主板過深,而始主板檢測CPU溫度失誤而自動保護關機。

AMD 64x2 X000+ CPU溫度高自動關機終級解決方法

  用名片的四個角把CPU墊高了。正常瀏覽網頁情況下溫度大降到30多到40多度左右,怎么樣,效果可怕吧,呵呵~~~~

方法二

CPU 開殼(不推薦)

“開殼”,也叫“開蓋”,即把CPU外殼打開,聽起來有點恐怖吧。呵呵,不要怕,讓我們慢慢來開殼。在講解之前,說明一下:CPU開殼是需要動手能力強的朋友才可操作哦,并且要非常有耐心,弄得不好,你的CPU就Game OVER了,所以,不到萬不得以,不要動此操作。

工具:AMD CPU開殼的工具很簡單,就只需要一個刀片即可。

AMD 64x2 X000+ CPU溫度高自動關機終級解決方法

  第一步:用刀片小心翼翼的從CPU的側邊慢慢劃開CPU粘膠,四周都要小心操作。操作時要小心別把CPU電路板劃到了,否則CPU就可能點不亮了哦~~~~

AMD 64x2 X000+ CPU溫度高自動關機終級解決方法

  操作第一步后,感覺差不多了,就用力將CPU散熱片與CPU芯片分離,如果分離不開,就還需要操作第一步

AMD 64x2 X000+ CPU溫度高自動關機終級解決方法

  操作完成后,就是這種效果,這才是我們adm 64X2 cpu的真身,是不是有點~~~~~~

接下來的事就不用我多說了吧,哎!還是哆嗦幾句;接下來就把CPU直接裝到主板上,在CPU上涂上導熱膏,裝上CPU散熱風扇,開機就OK了。這樣(CPU開殼)操作的目的是為了讓CPU直接與CPU散熱器底部接觸,更直接有效的給CPU降溫,從而達到更佳散熱的效果。


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->AMD 64×2 X000+ CPU溫度高自動關機終級解決方法!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12705.html/feed 0
Virtualbox的VBoxManage 命令詳解(二) http://www.bavghg.tw/archives/12704.html http://www.bavghg.tw/archives/12704.html#respond Sat, 22 Jun 2019 05:43:29 +0000 http://www.bavghg.tw/?p=12704 Virtualbox的VBoxManage 命令詳解(二)
VBoxManage addiscsidisk -server | 通過指定服務器名稱|ip地址添加ISCSI硬盤
-target 指定對象名稱字符串
[-port ] 指定ISCSI對象的服務端口號
[-lun ] 指定對象資源的邏輯單元編號
[-encodedlun ] 指定另一種格式的對象資源的邏輯單元編號
[-username ] 指定連接ISCSI對象的用戶名
[-password ] 指定連接ISCSI對象所需的密碼
[-comment ] 為這個連接添加一段描述性文字
比如:VBoxManage addiscsidisk -server 10.200.2.30 -target iqn.2000-12.com.acme:storage.lun0 -lun 0

VBoxManage createhostif 在宿主機添加一個指定名稱的虛擬網絡接口
VBoxManage removehostif | 從宿主機刪除指定UUID|名稱的虛擬網絡接口

VBoxManage getextradata global| 獲取全局設置信息
| 獲取指定UUID的虛擬機的信息
獲取指定名稱的虛擬機的信息
| 獲取與指定鍵值相關聯的數據信息
enumerate 列舉信息
比如:VBoxManage getextradata xp installdate 用于獲取虛擬機XP的安裝時間

VBoxManage setextradata global| 設置全局信息
| 設置指定UUID的虛擬機的信息
設置指定名稱的虛擬機的信息
指定要添加信息的鍵
[] 給上面的鍵添加鍵值(必須指定鍵值)
比如:VBoxManage setextradata xp installdate 2006.01.01 設置虛擬機xp的安裝時間為2006年1月1日

VBoxManage setproperty vdifolder default| 在全局設定里設置vdi目錄為默認
| 在全局設定里設置指定vdi目錄
machinefolder default| 在全局設定里設置虛擬機目錄為默認
| 在全局設定里指定虛擬機目錄
vrdpauthlibrary default| 在全局設定里設置VRDP證書為默認的證書 | 在全局設定里指定其他的VRDP證書
websrvauthlibrary default| 在全局設定里設置Web服務證書為默認的證書
null| 在全局設定里設置web服務證書為空 | 在全局設定里指定其他的Web服務證書
hwvirtexenabled yes|no 在全局設定里設置是|否支持硬件虛擬化
loghistorycount 在全局設定里設置日志數目,編號從0開始

VBoxManage usbfilter add 添加usb篩選器并設置它在篩選器列表中的位置
-target | 添加usb篩選器到指定UUID的虛擬機
| 添加usb篩選器到指定名稱的虛擬機
global 添加全局usb篩選器
-name 給usb篩選器指定名稱
-action ignore| 不允許虛擬機連接到篩選器
hold 允許虛擬機連接到篩選器(全局篩選器時)
[-active yes|no] 篩選器是|否生效(默認是生效)
[-vendorid ] 給usb篩選器指定vendorid(廠商標志)
[-productid ] 給usb篩選器指定productid(產品標志號)
[-revision ] 給usb篩選器指定revision(修訂版本號)
[-manufacturer ] 給usb篩選器指定manufacturer(制造商)
[-product ] 給usb篩選器指定product(產品標志)
[-remote yes|no] 指定usb篩選器是|否在遠程登陸時有效
[-serialnumber ] 給usb篩選器指定serialnumber(序列號)
[-maskedinterfaces ]
VBoxManage usbfilter modify 修改usb篩選器在列表中的順序
-target | 修改指定UUID的虛擬機的usb篩選器
| 修改指定名稱的虛擬機的usb篩選器
global 修改全局設置的usb篩選器
[-name ] 修改篩選器名稱
[-action ignore| 不允許虛擬機連接到篩選器
hold] 允許虛擬機連接到篩選器(全局篩選器時)
[-active yes|no] 篩選器是|否生效(默認是生效)
[-vendorid |””] 給usb篩選器指定vendorid(廠商標志)
[-productid |””] 給usb篩選器指定productid(產品標志號)
[-revision |””] 給usb篩選器指定revision(修訂版本號)
[-manufacturer |””] 給usb篩選器指定manufacturer(制造商)
[-product |””] 給usb篩選器指定product(產品標志)
[-remote yes|no] 指定usb篩選器是|否在遠程登陸時有效
[-serialnumber |””] 給usb篩選器指定serialnumber(序列號)
[-maskedinterfaces |””]

VBoxManage usbfilter remove 刪除指定序號的usb篩選器
-target | 刪除指定UUID的虛擬機的usb篩選器
| 刪除指定名稱的虛擬機的usb篩選器
global 刪除全局usb篩選器

VBoxManage sharedfolder add | 添加共享文件夾到指定名稱的虛擬機
添加共享文件夾到指定uuid的虛擬機
-name 指定共享文件夾名稱
-hostpath 指定共享文件夾所在的主機路徑
[-transient] 設置臨時共享
[-readonly] 設置共享為只讀

VBoxManage sharedfolder remove | 從指定名稱的虛擬機刪除共享文件夾
從指定UUID的虛擬機刪除共享文件夾
-name 刪除指定名稱的共享文件夾
[-transient] 臨時刪除

VBoxManage vmstatistics | 統計指定名稱的虛擬機的運行狀態信息
統計指定UUID的虛擬機的運行狀態信息
[-reset] 復位統計信息
[-pattern ] 設置信息的顯示格式
[-descriptions] 在統計信息中顯示描述信息

VBoxManage guestproperty get | 獲取指定名稱的虛擬機的預先設定的屬性值
獲取指定UUID的虛擬機的預先設定的屬性值 獲取指定屬性的預先設定的值
[-verbose] 以冗長的格式顯示

VBoxManage guestproperty set | 給指定名稱的虛擬機設置屬性值
給指定UUID的虛擬機設置屬性值 要設定值的屬性
[ 給屬性設定的值
[-flags ]] 設置一個標志

VBoxManage guestproperty enumerate | 列舉指定名稱的虛擬機的屬性值
列舉指定UUID的虛擬機的屬性值
[-patterns ] 列舉屬性值時采用的格式
VBoxManage metrics list [*| 顯示性能計數器
收集的所有系統資源的監測數據
host| 顯示性能計數器
收集的宿主機的系統資源的監測數據
顯示性能計數器
收集的虛擬機的系統資源的監測數據
[]] 要顯示的性能計數器列表

VBoxManage metrics setup 設置性能計數器
[-period ] 設置性能計數器的顯示周期
[-samples ] 設置性能計數器抽樣統計數
[*| 對所有資源設置設置性能計數器
host| 對宿主機資源設置設置性能計數器
對虛擬機資源設置設置性能計數器
[]] 性能計數器列表
例如:VBoxManage metrics setup -period 1 -samples 5 host CPU/Load,RAM/Usage

VBoxManage metrics query [*| 查找并顯示所有資源當前的性能計數器
host| 查找并顯示宿主機當前的資源的性能計數器
查找并顯示虛擬機當前的資源的性能計數器
[]] 性能計數器列表
例如:VBoxManage query host CPU/Load/User,CPU/Load/Kernel

VBoxManage metrics collect 收集性能計數器信息
[-period ] 設置性能計數器信息顯示的刷新周期
[-samples ] 設置性能計數器抽樣統計數
[-list] 顯示當前可以收集信息的性能計數器
[-detach]
[*| 收集所有系統資源的性能計數器信息
host| 收集宿主機資源的性能計數器信息
收集虛擬機資源的性能計數器信息
[]] 性能計數器列表


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->Virtualbox的VBoxManage 命令詳解(二)!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12704.html/feed 0
Virtualbox的VBoxManage 命令詳解(一) http://www.bavghg.tw/archives/12703.html http://www.bavghg.tw/archives/12703.html#respond Sat, 22 Jun 2019 05:42:46 +0000 http://www.bavghg.tw/?p=12703 Virtualbox的VBoxManage 命令詳解(一)
VBoxManage [-v|-version] 顯示virtualbox的版本號
VBoxManage -nologo 隱藏logo
VBoxManage -convertSettings 允許自動轉換設置文件
VBoxManage -convertSettingsBackup 允許自動轉換設置文件,并在轉換前作備份
VBoxManage -convertSettingsIgnore 允許自動轉換設置文件,但是不保存結果

VBoxManage list vms|runningvms 顯示列表虛擬機|正在運行的虛擬機
|ostypes|hostdvds virtualbox支持的系統類型|宿主機的光盤驅動器
|hostfloppies 宿主機的軟盤驅動器
|hostifs|hostinfo 宿主機的網絡接口|宿主機的信息
|hdds|dvds 已注冊的虛擬硬盤|已注冊的虛擬光盤
|floppies|usbhost 已注冊的虛擬軟盤|宿主機的USB設備
|usbfilters USB篩選器
|systemproperties 虛擬機的基本信息

VBoxManage showvminfo | 顯示指定虛擬機的信息
[-details] 顯示詳細信息
[-statistics] 顯示統計信息
[-machinereadable] 以清晰的格式顯示虛擬機信息

VBoxManage registervm 將指定文件所在的虛擬機添加到列表

VBoxManage unregistervm | 從虛擬機列表清除指定的虛擬機
[-delete] 從虛擬機列表刪除指定的虛擬機

VBoxManage createvm -name 創建指定名稱的虛擬機
[-register] 將創建的虛擬機添加到列表
[-basefolder 指定虛擬機的基礎目 錄
[-settingsfile ] 指定虛擬機配置文件的基礎目錄
[-uuid ] 創建指定uuid的虛擬機

VBoxManage modifyvm 編輯指定的虛擬機的配置
[-name ] 修改虛擬機的名稱
[-ostype ]修改虛擬機的操作系統類型
[-memory ] 修改虛擬機的內存大小
[-vram ] 修改虛擬機的顯存大小
[-acpi on|off] 啟動或禁止acpi電源管理接口
[-ioapic on|off] 啟動或禁止I/O APIC電源管理接口
[-pae on|off] 啟動或禁止CPU的PAE支持,PAE是 Physical Address Extension : 物理地址擴展
[-hwvirtex on|off|default]啟動或禁止CPU的硬件虛擬化支持
[-nestedpaging on|off] 開啟或關閉CPU的嵌套頁面列表支持
[-monitorcount ] 設置顯示器數目,VRDP多用戶模式時
[-bioslogofadein on|off] 開啟或關閉bioslogo漸顯效果
[-bioslogofadeout on|off] 開啟或關閉bioslogo漸隱效果
[-bioslogodisplaytime ]設置bioslogo顯示時間(以毫秒為單位)
[-bioslogoimagepath ]設置bioslogo圖像路徑,用于自定義bioslogo
[-biosbootmenu disabled| 設置是否顯示bios啟動菜單 關閉
menuonly| 只菜單
messageandmenu] 信息和菜單
[-biossystemtimeoffset ] 設置bios系統時間補償(以毫秒為單位)
[-biospxedebug on|off] 打開或關閉biospxe調試
[-boot<1-4> none|floppy|dvd|disk|net>] 設置啟動順序
[-hd none||] 為虛擬機添加三個IDE設備之一(第2個主盤被vm保留作為光驅,不能占用)在三個IDE中,你可以指定(硬盤)的vdi文件名或者它的UUID
[-idecontroller PIIX3|PIIX4] 設置IDE控制器的類型
[-sata on|off] 開啟或關閉SATA硬盤控制器
[-sataportcount <1-30>] 設置虛擬機最多支持的SATA控制器數目
[-sataport<1-30> none| 沒有硬盤連接到SATA控制器
| 指定uuid的硬盤連接到SATA控制器
] 指定文件名的硬盤連接到SATA控制器
[-sataideemulation<1-4> <1-30>] 指定一個SATA設備工作在IDE兼容模式,IDE設備編號是1-4,SATA設備編號是1-30
[-dvd none| 不連接DVD光驅
| 指定UUID的DVD光驅連接
| 將指定的光盤映像文件掛接到DVD光驅
host:] 將宿主機的DVD光驅掛接到虛擬機的DVD光驅
[-dvdpassthrough on|off]打開|關閉虛擬機里光盤的刻錄功能
[-floppy disabled| 不連接軟驅
empty| 連接軟驅但不插入軟盤
| 指定UUID的軟驅連接
| 將指定的軟盤映像文件掛接到軟驅驅
host:] 將宿主機的軟驅驅掛接到虛擬機的軟驅
[-nic<1-N> none| 虛擬機不添加網卡
null| 虛擬機有網卡但不連接
nat| 網絡連接使用NAT模式
hostif| 網絡連接使用橋接模式
intnet] 網絡連接使用內部網絡模式
[-nictype<1-N> Am79C970A| 虛擬機連接AMD PCNet PCI II網卡
Am79C973| 虛擬機連接AMD PCNet FAST III網卡(默認)
82540EM| 虛擬機連接Intel PRO/1000 MT Desktop網卡
82543GC] 虛擬機連接Intel PRO/1000 T Server網卡
[-cableconnected<1-N> on|off]插入或拔出網線
[-nictrace<1-N> on|off] 開啟或關閉網絡追蹤
[-nictracefile<1-N> ] 將網絡流量追蹤數據保存到文件
[-nicspeed<1-N> ] 設置網絡連接的速度
[-hostifdev<1-N> none| 不連接到主機網絡接口
] 橋接模式下連接到指定的主機接口
[-intnet<1-N> ] 內網模式下為虛擬機指定內部網絡名稱
[-natnet<1-N> | 配置NAT網絡接口的地址
default] 默認NAT網絡接口的地址是10.0.x.0/24
[-macaddress<1-N> auto| 自動生成虛擬網卡的MAC地址
] 指定虛擬網卡的MAC地址
[-uart<1-N> off| 不啟用虛擬串口
]啟用虛擬串口,并設置虛擬串口的I/O參數和IRQ參數
[-uartmode<1-N> disconnected| 啟用虛擬串口,但不連接到宿主機的串口
server | 在宿主機創建PIPE通道,并將虛擬機串口連接到這個通道
client | 不創建PIPE通道,而是將虛擬機串口連接到已存在的通道
] 將虛擬機串口連接到宿主機的串口
[-gueststatisticsinterval ] 配置虛擬機靜態時間間隔
[-audio none| 虛擬機不連接聲卡
null| 將虛擬機的聲卡連接到空的聲音設備
dsound] 將虛擬機的聲卡連接到宿主機的聲卡
[-audiocontroller ac97| 將虛擬機聲卡虛擬為ICH AC97聲卡
sb16] 將虛擬機聲卡虛擬為soundblaster 16聲卡
[-clipboard disabled| 不共享剪貼板
hosttoguest| 將宿主機的剪貼板共享給虛擬機
guesttohost| 將虛擬機的剪貼板共享給宿主機
bidirectional] 宿主機和虛擬機共使用一個剪貼板
[-vrdp on|off] 開啟|關閉virtualbox內置的VRDP服務器
[-vrdpport default| 使用默認的vrdp端口3389 ] 指定vrdp端口
[-vrdpaddress ] 指定VRDP主機地址
[-vrdpauthtype null| 不用授權,任何客戶機都可以連接到VRDP服務器
external| 只有宿主機的用戶才可以連接到VRDP服務器
guest] 只有虛擬機的用戶才可以連接到VRDP服務器
[-vrdpmulticon on|off] 打開|關閉VRDP多用戶連接模式
[-vrdpreusecon on|off] 打開|關閉VRDP斷線重連
[-usb on|off] 打開|關閉虛擬USB控制器
[-usbehci on|off] 打開|關閉虛擬USB2.0控制器
[-snapshotfolder default| 將系統快照保存到默認文件夾 ] 將系統快照保存到指定文件夾

VBoxManage startvm | 開啟指定UUID|名稱的虛擬機
[-type gui|vrdp] 設置虛擬機標準顯示設備GUI界面|VRDP

VBoxManage controlvm | 改變正在運行的虛擬機的狀態
pause| 暫停,這時虛擬機窗口顯示灰色
resume| 恢復暫停的虛擬機
reset| 復位
poweroff| 強行關閉
acpipowerbutton| 關機
acpisleepbutton| 使虛擬機處于睡眠狀態
savestate| 保存狀態然后關閉,相當于休眠
keyboardputscancode [ …] 鍵盤掃描碼設置
setlinkstate<1-4> on|off 連接|斷開網絡連接
usbattach |

連接到指定UUDI|地址的USB設備
usbdetach |

斷開指定UUDI|地址的USB設備
dvdattach none| 不連接虛擬DVD光驅
| 連接到指定UUID的DVD光驅
| 連接到指定名稱的DVD映像文件
host: 連接到宿主機的DVD光驅
floppyattach none| 不連接虛擬軟驅
| 連接到指定UUID的虛擬軟驅
| 連接到指定名稱的軟盤映像文件
host: 連接到宿主機的軟驅

setvideomodehint 設置虛擬機的屏幕分辨率 水平像素
垂直像素
顏色深度
[display] 刷新頻率
setcredentials 指定VRDP自動連接參數 用戶名 密碼

[-allowlocallogon ] 允許|禁止本地登陸

VBoxManage discardstate | 丟棄指定UUID|名稱的虛擬機的保存狀態

VBoxManage adoptstate | 將虛擬機從指定的保存狀態中恢復

VBoxManage snapshot | 為指定的虛擬機拍快照
take 為快照取名
[-desc ]| 給快照添加描述
discard | | 丟棄指定的快照
discardcurrent -state| 恢復到最近的快照
-all | 恢復到倒數第二個快照
edit || 編輯指定的快照
-current 編輯當前快照
[-newname ] 修改快照名稱
[-newdesc ] 修改快照描述
showvminfo | 顯示快照的虛擬機信息

VBoxManage registerimage disk|dvd|floppy 注冊硬盤、光盤、軟盤映像文件
[-type normal| 注冊為普通類型(可創建快照,可讀寫)
immutable| 注冊為只讀類型(相當于加了硬盤卡)
writethrough] 注冊為可寫類型(這種類型不能創建快照)
(disk only) (注冊類型選項只適用于硬盤)

VBoxManage unregisterimage disk| 從虛擬介質管理器刪除指定的硬盤
dvd| 從虛擬介質管理器刪除指定的DVD光盤
floppy 從虛擬介質管理器刪除指定的軟盤
| 刪除時指定UUID
刪除時指定映像文件

VBoxManage showvdiinfo | 顯示指定UUID|名稱虛擬硬盤的信息

VBoxManage createvdi -filename 創建指定名稱的虛擬硬盤
-size 指定虛擬硬盤的大小(以兆為單位)
[-static] 創建固定大小的虛擬硬盤
[-comment ] 添加一段解釋性文字
[-register] 注冊新創建的虛擬硬盤
[-type normal| 注冊類型 普通(可以創建快照)
writethrough] 注冊類型 可寫(不能創建快照)
(default: normal) 默認是普通類型
VBoxManage modifyvdi | compact 壓縮指定的虛擬硬盤

VBoxManage clonevdi | 克隆指定的VDI虛擬硬盤

VBoxManage convertdd [-static] 將raw硬盤轉換成vdi虛擬硬盤
VBoxManage convertdd [-static] stdin 將標準輸入參數指定的設備轉換成vdi虛擬硬盤,比如:dd if=/dev/sda1 | VBoxManage convertdd stdin /media/disk/C.vdi 62277025792


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->Virtualbox的VBoxManage 命令詳解(一)!在下邊可以分享本文哦!
]]> http://www.bavghg.tw/archives/12703.html/feed 0 克隆Virtualbox的vdi硬盤 和 修改uuid http://www.bavghg.tw/archives/12702.html http://www.bavghg.tw/archives/12702.html#respond Sat, 22 Jun 2019 05:38:00 +0000 http://www.bavghg.tw/?p=12702 將一個創建好的vdi(最主要的是配置的環境)快速變成多個vdi,以便供其它虛擬主機使用。
克隆Virtualbox的vdi硬盤 和 修改uuid

步驟

1、在cmd環境下,cd 到virtualbox的安裝目錄下,如:

cd F:\softer\VirtualBox

2、該目錄下有個VBoxManage.exe,可以調用該程序命令:

VBoxManage clonemedium [源vdi文件路徑] [目的vdi文件路徑]
VBoxManage clonemedium F:\softer\VirtualBox\VDI\test.vdi F:\softer\VirtualBox\VDI\test_hdl.vdi

下面方法也可以作為另外一種重用vdi

1、直接右鍵復制vdi文件,這時候可以給該vdi重命名。
2、在cmd,仍然要cd到安裝目錄下,使用命令

VBoxManage internalcommands sethduuid [復制之后的vdi]

這樣就成了一個新的vdi了。

遷移vdi

1、由于電腦C盤空間告急,而整個virtualbox安裝完系統后占用了6.7G,于是決定把virtualbox默認安裝目錄下的.vdi遷移到其它盤下;
2、virtualbox的虛擬磁盤文件所在默認目錄:C:\Users\huanghuang\VirtualBox VMs\ubuntu,刪除該目錄下的文件:.vbox、.vbox-prev; 把.vdi遷移到你需要放的目錄下面;
3、新建虛擬電腦;
4、下一步;
5、使用現有的.vdi文件(遷移目錄下);
6、create;
7、成功;


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->克隆Virtualbox的vdi硬盤 和 修改uuid!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12702.html/feed 0
VirtualBox 修改UUID實現虛擬硬盤復制 http://www.bavghg.tw/archives/12700.html http://www.bavghg.tw/archives/12700.html#respond Sat, 22 Jun 2019 02:42:43 +0000 http://www.bavghg.tw/?p=12700 VirtualBox 修改UUID實現虛擬硬盤復制
VBoxManage 其實就是虛擬機安裝目錄下的VBoxManage.exe文件,使用時,最好先在命令行中利用cd定位到安裝目錄下,例如“C:\Program Files\Oracle\VirtualBox\”。
然后再輸入命令VBoxManage internalcommands sethduuid,命令后面跟的是虛擬機文件的地址,例如:vmbx文件,則完整的命令就是

VBoxManage internalcommands sethduuid ?D:/work_software/1230/ubutu.vmbx

在命令行中,打開VirtualBox的文件夾,輸入以下命令:

VBoxManage internalcommands sethduuid "E:\VirtualBox VMs\XP.vdi"

會提示:

UUID changed to: fcc11a69-8b47-4090-a118-67ad29f12d6c

(UUID,隨機生成)

重新掛載就可以了.

注意:VBoxManage?最好先用cd定位過去,而不要在命令行中指定,容易出錯。

版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->VirtualBox 修改UUID實現虛擬硬盤復制!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12700.html/feed 0
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法 http://www.bavghg.tw/archives/12671.html http://www.bavghg.tw/archives/12671.html#respond Fri, 21 Jun 2019 03:15:05 +0000 http://www.bavghg.tw/?p=12671 軟件簡介

Lumion9.0.2 中文特別版安裝圖文教程、注冊方法
lumion9.0是lumion系列軟件的新版本,也是止目前建筑師可用的世界上最快速的三維渲染軟件之一,能夠在幾秒鐘內,以視頻或圖像形式可視化具有逼真背景和驚人藝術感的CAD模型。新版本在比以往更快地捕捉逼真場景的同時,還可以讓項目立即變得生動起來。比如lumion9.0添加了一鍵式真實天空,投射新的光影到場景,立即為設計創造一個漂亮、獨特的背景,讓真實雨景傳達舒適的空間,并用毛茸茸的地毯和蓬松的毯子裝飾。另外新改進的場景構建工具可以幫助您在幾分鐘內創建復雜的環境,除了改進的工作流程,還可以在所有項目中盡情享受lumion9.0令人驚嘆的渲染速度和卓越的圖像及視頻,讓你輕松的建立與客戶的密切關系。

安裝注冊

下載Lumion9.0.2壓縮包
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖1)
壓縮包下載成功后,鼠標右擊解壓到當前文件。如圖1。

End

02安裝主應用程序
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖2)
打開解壓出來的文件夾,雙擊Lumion9.0.2應用程序。如圖2。

End

03選擇安裝路徑
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖3)
點擊游覽,選擇安裝路徑,也可不用選,點擊下一步。如圖3。

End

04創建桌面快捷方式
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖4)
默認勾選了創建桌面快捷方式,點擊下一步。如圖4。

End

05確認安裝
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖5)
查看安裝信息,點擊安裝,開始安裝。如圖5。

End

06耐心等待安裝
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖6)
軟件正在安裝中,耐心等待片刻即可安裝成功。如圖6。

End

07安裝完成
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖7)
等待十幾分鐘之后,軟件就成功安裝了,然后點完成。如圖7。

End

08復制破解文件
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖8)
打開Crack解壓文件,復制里面的破解文件和補丁。如圖8。

End

09粘貼破解文件
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖9)
鼠標右擊軟件快捷方式,打開文件所在位置,在空白處鼠標右擊粘貼。如圖9。

End

010復制和替換
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖10)
先點擊勾選左下角的小框,在點擊復制和替換。如圖10。

End

011確認文件夾替換
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖11)
再次點擊勾選左下角的小框,點擊是。如圖11。

End

012運行軟件
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖12)
雙擊電腦桌面的Lu9.0快捷方式,如果報錯,點擊確定。然后界面會出現一會空白,這時候請你耐心的等待一會會。如圖12。

End

013軟件正在讀取
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法(圖13)
此時下面的進度條正在慢慢的讀取,會有點慢,請耐心等待。如圖13。

End

014軟件界面
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法

下載地址

下載后自行測試是否有病毒

轉自:3D66
Lumion9.0.2 中文特別版安裝圖文教程、注冊方法
此處內容已經被作者無情的隱藏,請輸入驗證碼查看內容
驗證碼:
請關注“HongHuiDianNao”官方微信公眾號,回復關鍵字“關鍵字”,獲取驗證碼。【注】用手機微信掃描右側二維碼都可以關注“HongHuiDianNao”官方微信公眾號。


版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->Lumion9.0.2 中文特別版安裝圖文教程、注冊方法!在下邊可以分享本文哦!
]]>
http://www.bavghg.tw/archives/12671.html/feed 0
中国福利彩票36选7开奖结果