• 歡迎訪問奇跡の海網站,本站不上傳任何資源,所有資源均來自于網絡,歡迎加入奇跡の海~!奇跡の海-WordPress QQ群
  • 本站下載資源為網絡上收集整理而來,并且以計算機技術研究交流為目的,版權歸原作者所有,僅供大家參考,學習,不存在任何商業目的與商業用途.
  • 本站系統鏡像均來自于官方原版,ed2k可視為P2P下載鏈接。所有操作系統默認均為試用版,如有正版密鑰可以有效激活,本站不提供任何激活和相關服務。

易語言怎么寫關聯文件源碼

易語言 奇跡の海 2年前 (2018-05-12) 479次瀏覽 已收錄 0個評論 掃描二維碼

易語言怎么寫關聯文件源碼
文件是RACK格式的 需要關聯D盤的vdsnm.exe這個文件

源碼

.版本 2
  
_文件關聯 (“D:\vdsnm.exe”, “rack”, “D:\vdsnm.exe”)
 
.子程序 _文件關聯
.參數 關聯應用程序, 文本型, , 當雙擊對應的文件時就運行該應用程序打開
.參數 關聯文件類型, 文本型, , 欲關聯的文件類型,如“mp3”
.參數 關聯文件圖標, 文本型, , ICQ文件路徑或EXE文件路徑,注銷后才有效
.參數 設置默認, 邏輯型, , 是否設為默認
.如果真 (設置默認)
    刪除注冊項 (#現行用戶, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 關聯文件類型 + “\OpenWithList”)
    刪除注冊項 (#現行用戶, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 關聯文件類型 + “\OpenWithProgids”)
    刪除注冊項 (#現行用戶, “Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.” + 關聯文件類型 + “\”)
.如果真結束
寫注冊項 (#根類, “.” + 關聯文件類型 + “\”, 關聯文件類型 + “file”)
寫注冊項 (#根類, 關聯文件類型 + “file\”, 關聯文件類型)
寫注冊項 (#根類, 關聯文件類型 + “file\DefaultIcon\”, 關聯文件圖標 + “,0”)
寫注冊項 (#根類, 關聯文件類型 + “file\shell\open\command\”, 關聯應用程序 + “ ” + #引號 + “%1” + #引號)

方法

_文件關聯 (“D:\vdsnm.exe”, “rack”, “D:\vdsnm.exe”,假)

版權聲明:本站所有文章和資源使用CC BY-NC-SA 4.0協議授權發布 , 轉載應當以相同方式注明文章來自“SeaOMC.COM->易語言怎么寫關聯文件源碼!在下邊可以分享本文哦!
喜歡 (0)
[]
分享 (0)
奇跡の海
關于作者:
一個WordPress菜鳥!
發表我的評論
取消評論

表情 貼圖 加粗 刪除線 居中 斜體 簽到

Hi,您需要填寫昵稱和郵箱!

  • 昵稱 (必填)
  • 郵箱 (必填)
  • 網址
中国福利彩票36选7开奖结果